当前位置:首页 >  问答

通达信股价高点压力阻力支撑公式附教程

我来帮TA回答

请大师给个通达信支撑位和压力位公式指标

1、公式一
{压力支撑}
收:C,LINETHICK0;
开:O,LINETHICK0;
最高:H,LINETHICK0;
最低:L,LINETHICK0;
P:=(H+L+C)/3;
压1:(P*2)-L;
支1:(P*2)-H;
压2:P+(压1-支1);
支2:P-(压1-支1);
压3:H+2*(P-L);
支3:L-2*(H-P),COLORFFFF33;
压4:H+3*(P-L);
支4:L-3*(H-P);
2、公式二
上市日期:FINANCE(42)/100, NODRAW ;
VAR1:=MA(CLOSE,5),COLOR00FFFF;
VAR2:=MA(CLOSE,13),COLOR00FF33;
VAR5:=MA(CLOSE,34),COLORFF9900;
VAR6:=MA(CLOSE,54),COLORFF9900;
VAR7:=((EMA(CLOSE,5)*7+EMA(CLOSE,5)*3)/10),COLORBBBBBB;
VAR8:= DMA(EMA(CLOSE,12),SUM(VOL/CAPITAL,5)/3),LINETHICK2;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(84,VARE),HIGH,'☆机构减仓'),COLORGREEN;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
VAR14:=LLV(LOW,120);
VAR15:=HHV(HIGH,120);
VAR16:=VAR15-VAR14;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VAR12>VAR13,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,'★机构进场'),COLORYELLOW;
STICKLINE(VAR7>VAR2,VAR2,VAR7,0.01,1),COLORFF00FF;
STICKLINE(VAR7<VAR2,VAR2,VAR7,0.01,1),COLOR33FF33;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑价:LLV(LOW,19) , COLOR009900,LINETHICK2;
阻力价:HHV(HIGH,19),COLORFF9900, LINETHICK2;
VAR4:EMA(C,21),COLOR0000FF, LINETHICK2;
副图公式。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

跪求通达信分时压力,支撑,主图公式!

突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,10,0),COLOR000099;
STICKLINE(A1X<0,空方,突破,10,0),COLOR00CC66;
EE:=(H+L+O+2*C)/5;
CRTP:=EE+(H-L);
CRZL:=2*EE-L;
CRZC:=2*EE-H;
CRFZ:=EE-(H-L);
顶:CONST(CRTP),COLORRED;
压:CONST(CRZL),COLORC7C9FF;
撑:CONST(CRZC),COLOR7C9CFF;
跳:CONST(CRFZ),COLORDD00DD;
弹:MA(CLOSE,3);
支撑:EXPMA(CLOSE,40);
起涨:MA(C,13),COLOR00FFFF,LINETHICK2;
涨:IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,13)=REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(CLOSE,13)<REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORGREEN,LINETHICK2;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR,跳 , '跳起'),LINETHICK1,COLORDD00DD;
DRAWTEXT(ISLASTBAR,撑 , '撑力'),LINETHICK1,COLOR7C9CFF;
DRAWTEXT(ISLASTBAR,压 , '压力'),LINETHICK1,COLORC7C9FF;
DRAWTEXT(ISLASTBAR,顶 , '顶破'),LINETHICK1,COLOR0000FF;
A:MA(C,10)<MA(C,24) AND COUNT(CROSS(MA(C,5),MA(C,10)),10) AND REF(L,1)<REF(MA(C,10),1) AND REF(C,1)<REF(MA(C,5),1) AND C>REF(H,1) AND REF(C,1)<REF(H,2) AND COUNT(MA(C,10)>REF(MA(C,10),1),5)>1,NODRAW;
B:MA(C,10)>MA(C,24) AND REF(L,1)<REF(MA(C,24),1)*1.01 AND C>REF(H,1) AND REF(C,1)<REF(H,2) AND REF(C,1)<REF(H,2),NODRAW;
DRAWICON(A,L-0.10,16);
DRAWICON(B,L-0.10,17);
HH:=LLV(L,7)*1.13-0.03;
STICKLINE(H>=HH,H,H*1.005,1,0),COLOR00FFFF;
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
日跌:L*0.989,NODRAW,COLORFF00FF;
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P11:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P22:=今小前;
DL:=P11=1 AND REF(P11,1)=0 AND P22=1 AND REF(P22,1)=0;
STICKLINE(DL,O,C,0.1,0),COLORAAAAAA;
BB :=MAX(C,O)-(REF(MAX(C,O),2)-MAX(C,O))/2;
买点:=(H-(REF(H,2)-H)/2);
AA:MAX(BB,买点),NODRAW,COLORFF00FF;
STICKLINE(C<O AND F<-3 AND F>-5,C+(O-C)/3,C+(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<-3 AND F>-5,C+2*(O-C)/3,C+2*(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<=-5 AND F>-7,C+(O-C)/2,C+(O-C)/2,2.5,0),COLORYELLOW;
STICKLINE(C<O AND F<=-7 AND F>-10,C+2*(O-C)/3,C+(O-C)/3,2.5,1),COLORYELLOW;
STICKLINE(C<O AND F<=-9.9,O,C,2.5,0),COLOR00FF00;
STICKLINE(C>O AND F>2.9 AND F<5,O+(C-O)/3,O+(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>2.9 AND F<5,O+2*(C-O)/3,O+2*(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=5 AND F<7,O+(C-O)/2,O+(C-O)/2,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=7 ,O+2*(C-O)/3,O+(C-O)/3,2.5,1),COLORYELLOW;
A1:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B1:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B1,B1,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),COLORWHITE,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;
IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);
IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头};

通达信怎么改支撑位和压力位公式

有。一般情况下连续上涨20%,就会在下一个交易日停盘一个小时,公告相关的信息。

求助:股票压力支撑位公式源码。 要求:使用于通达信软件,并且验证后符合问题补充的要求。

到现在还能相信这些所谓的指标和压力、支撑吗

通达信如何使用选股公式

公式如下:
every(c<o,3);

通达信 修改为 选大牛的选股公式

VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0);
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
XG:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;